2012-01-18 11:18:03
  • you may get errors if trying to install pyglet using the traditional way, using pip for instance (was my case on MacOs X Lion 10.7.0 + python 64bits from EPD or homebrew). in cause is the carbon code that has been abandonned in the 64bits libraries that come with the OS
  • the solution comes from the https://code.google.com/p/cocoa-python/ package
    1. clone the package hgclonehttps://code.google.com/p/cocoa-python
    2. insert the code in your PYTHONPATH: rsync-avcocoapy/usr/local/lib/python2.7/site-packages/pyglet/libs/darwin
  • a simpler solution is to install the pyglet code from https://code.google.com/r/evilphillip-cocoa-ctypes2/ :
    1. hgclonehttps://code.google.com/r/evilphillip-cocoa-ctypes2/
    2. cdevilphillip-cocoa-ctypes2/
    3. pythonsetup.pyinstall
  • works!